TOUTSIMCITIES

Bug sur l'interface de la région (RESOLU)

message posté le 11 juil 2015 à 00h03(message édité)édité le 20 juil 2016 à 15h48 par Akallan

Avatar

Akallan

  • membre
  • Suisse, Neuchâtel
Bonsoir à tous,

Je refais encore un sujet! ^^

J'ai un autre soucis encore ce soir, qui celui là persiste depuis déjà des mois, peut être que vous avez remarqué sur les photos de mon sujet nommé "Dahammas" qui certaines tuiles de mes villes ont un problème d'affichage que je ne serais très bien expliquer. Alors j'ai fais un screen pour vous montrer en espérant que vous savez d'où vient le problème:

Légende:
- Encadré rouge: grandes parcelles où l'on voit totalement le problème d'affichage
- Traitillé rouge: grandes parcelles où l'on voit que partiellement ou pas du tout le bug (recouvert par des constructions ou de la forêt par exemple)

Image non décrite

Alors pour informations:
- J'ai déjà désinstallé et réinstallé le jeu afin de savoir si cela provenait du jeu lui même, hé bien non.
- J'ai enlevé le dossier "Plugins" du dossier de Sim City 4 afin de jouer avec le jeu à l'état pure sans aucuns mods, cela ne fonctionne non plus pas.


Je ne sais donc pas d'où vient le problème, je joue sur un PC Windows 8.1 / 64-Bit, avec une carte Nvidia GeForce GTX 650 fraichement mit à jour ce soir. Peut-on m'aider? :???:

message posté le 11 juil 2015 à 19h54

Avatar

Akallan

  • membre
  • Suisse, Neuchâtel
Salut, merci de ta réponse!

J'ai donc tenté de suivre les démarches que tu m'as citées, mais rien ne fonctionne... :/
Le jeu avait les compatibilités par défaut le "Windows XP (pack 2)", j'ai donc essayé avec le Windows 7 et le 8. J'ai même essayé de le lance en administrateur mais non plus!
Ensuite j'ai essayé ta solution numéro 2, j'ai d'abord essayé avec en "Logiciel", ensuite j'ai descendu la résolution au minimum (600x800 je crois), et les graphismes pareils, malgré tout, ces bordures sur les tuiles de la région ne disparaisse pas! :snif:

message posté le 17 juil 2015 à 21h01

Avatar

Zed68

  • membre
  • Ma chaise
Je crois avoir vu que ce souci venait des hautes résolutions... as-tu essayé de relancer le jeu dans une résolution "d'origine", mais resauvegardé les villes dans cette résolution ?

message posté le 17 juil 2015 à 21h56

Avatar

supremec

  • équipe BAT TSC
  • France, Nord
Qu'est-ce qu'on peut lire de nos jours :aie:

Je confirme les dires de Zed68.
Simcity 4 a ces limites technologiques et aujourd'hui, on a des ordis bien plus puissant qu'il y a 12 ans (normal). Il y a 12 ans personne n'avait de résolution 1920x1080 et je dirais même que le format 16:9ème n'était pas démocratisé sur les écrans PC :fou:

Dans ce cas, il faut utiliser une résolution qui va bien. Pour cela, il faut en tester plusieurs.
Si tu lance SimCity 4 depuis un raccourci (recommandé de nos jours :D ), il suffira d'ajouter à la fin du champ Cible:
-CustomResolution:enabled -raaaaxbbbbx32
aaaa et bbbb représentent des nombres correspondant à ta résolution.

Exemple de mon champ cible:
"C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe" -intro:off -CPUcount:1 -w -CustomResolution:enabled -r1680x1050x32

-intro:off enlève l'introduction du jeu.
-CPUcount:1 est vivement recommandé, sinon ton jeu risque de planter, si tu possède plus d'un processeur.
-w veut dire que je veux mon jeu en mode fenêtré

Il faut, en revanche, obligatoirement re-sauvegarder les villes pour que le bug disparaisse.
Si je t'explique mieux comment Sim City 4 gère cela: au moment où l'on sauvegarde une ville, Simcity 4 se charge de faire une image de la ville afin de l'afficher sur la région: ce qui explique le fait que tu ne vois pas de changements juste en changeant la résolution.

message posté le 24 juil 2015 à 20h33

Avatar

Akallan

  • membre
  • Suisse, Neuchâtel
Merci supremec pour ta réponse, je rentre fraichement de vacance, je testerai donc ta solution dans les jours à venir et je te redonnerai des nouvelles! :)

message posté le 27 juil 2015 à 20h28

Avatar

Akallan

  • membre
  • Suisse, Neuchâtel
Salut supremec, alors j'ai testé ce que tu m'as dis, mais je bloque sur la cible...

Je fais un clic droit sur le logo de SC4 qui est sur le bureau, donc le raccourci comme tu as dis. Ensuite je me dirige vers le l'onglet "Raccourci" et j'ajoute ce que tu demandes dans le champ "Cible" comme ceci avec ma résolution voulue:

"C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe"-intro:off-CPUcount:1-CustomResolution:enabled-r1600x1200x32

J'ai volontairement enlevé le "-w" ainsi que fermé les espaces qu'il y avait entre chaque "code". Car avec les espaces ça ne fonctionne pas, alors j'ai essayé sans, mais non plus. Est-ce qu'il y a quelque chose que je fais de faux? A chaque fois que je veux valider les modifications apportées dans "Cible", un message d'erreur survient:

Image non décrite

Merci d'avance pour ton aide!

message posté le 30 juil 2015 à 12h00

Avatar

phalanxs

  • maître wiki
  • Sud-ouest
Je ne suis pas sur mon ordi en ce moment donc je ne fais que deviner, mais peut-etre qu'il faut déplacer/enlever les guillemets ?

Artica vous attend, sur le forum et sur le wiki !

message posté le 30 juil 2015 à 13h07

Avatar

Akallan

  • membre
  • Suisse, Neuchâtel
Ne fonctionne pas non plus, je l'avais essayé. Merci quand même! ;)

message posté le 30 juil 2015 à 18h51

Avatar

Dezelle

  • membre
  • Marseille/Provence/France
Perso, sous Windows 8, je n'ai jamais réussi à paramétrer le démarrage de SC4 via une ligne de commande dans la "Cible"... :(

Mais rien ne t'empêche de démarrer SC4 et de modifier les paramètres... :|
Après redémarrage, ma configuration était prise en compte...

message posté le 30 juil 2015 à 20h44(message édité)édité le 30 juil 2015 à 20h45 par supremec

Avatar

supremec

  • équipe BAT TSC
  • France, Nord
Salut Akallan,
Je reviens vers toi pour te dire qu'il faut un espace entre chaque paramètres (les paramètres commencent par le tiret) ;)